import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?!.*are)(?!.*how).*(hello)";
final String string = "hello how are you\n"
+ "how hello are you\n"
+ "are hello how you\n"
+ "hello\n"
+ "are hello\n"
+ "how hello\n"
+ "bye hi hello\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}