$re = '/^(?!.*are)(?!.*how).*(hello)/m';
$str = 'hello how are you
how hello are you
are hello how you
hello
are hello
how hello
bye hi hello
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);