re = /^(?!.*are)(?!.*how).*(hello)/m
str = 'hello how are you
how hello are you
are hello how you
hello
are hello
how hello
bye hi hello
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end