re = /(?<=:)"(\w+)"/m
str = '{"IconBtn":"Abtn","AppBtn":"ABtn"}
{"IconBtn":"Abtn"}'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result