#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?<=foo)\d*(?=.*(?:\R(?!foo\d).*)*bar)"
Local $sString = "foo1" & @CRLF & _
"some text" & @CRLF & _
"foo12" & @CRLF & _
"some text" & @CRLF & _
"bar" & @CRLF & _
"some text" & @CRLF & _
"foo123" & @CRLF & _
"some text" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")