use strict;
my $str = 'Pseudo-example:
Sentence of the first [^a]paragraph. Sentence[^b] of the first[^b] paragraph[^1]. Sentence of the first[^1] paragraph. Sentence[^1] of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph. Sentence of the first paragraph.
[^a] Sentence of a long margin note\'s body that refers to the word "paragraph".
[^1] Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote. Sentence of the first paragraph of the footnote.
Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote. Sentence of the second paragraph of the footnote.
Sentence of the third and the last paragraph of the footnote and two empty lines after it!
Sentence[^1] of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph. Sentence of the second paragraph.
[^b] Footnote at the end of the file. Footnote at the end of the file. Footnote at the end of the file';
my $regex = qr/^(\[\^)([^\s\p{C}\]]+)(\])\ ([\P{C}\n]*?)(?=\n\[|\n\n\n|\Z)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}