use strict;
my $str = ' 25д10ч3м10с
15м30с';
my $regex = qr/ \d{1,2}[д]\d{1,2}[ч]\d{1,2}[м]\d{1,2}[с]|\d{1,2}[м]\d{1,2}[с]/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}