#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+):[0-9]+\n(^\1:[0-9]+\n){1,}"
Local $sString = "172.27.0.1:22" & @CRLF & _
"172.27.0.1:21" & @CRLF & _
"172.27.0.1:23" & @CRLF & _
"172.27.0.1:23" & @CRLF & _
"172.27.0.1:23" & @CRLF & _
"172.27.0.1:25" & @CRLF & _
"172.27.0.1:25" & @CRLF & _
"172.27.0.1:24" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")