import Foundation
let pattern = #"^([0-9]+\.[0-9]+\.[0-9]+\.[0-9]+):[0-9]+\n(^\1:[0-9]+\n){1,}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
172.27.0.1:22
172.27.0.1:21
172.27.0.1:23
172.27.0.1:23
172.27.0.1:23
172.27.0.1:25
172.27.0.1:25
172.27.0.1:24
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)