using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\|\w+;(Data\d+;\d+;\d+)";
string input = @"""12121|a;Data1;234;121|b;Data2;235;122|c;Data3;236;123;[-]mass1;112;1212;1212;1212;1212""
----
Data1;234;121
Data2;235;122
Data3;236;123";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}