package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)section\/([^\/#]*)`)
var str = `https://www.test.com/en/section/string-to-get#id=4949
https://www.test.com/en/section/string-to-get/page&2#id=4949`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}