re = /section\/([^\/#]*)/m
str = 'https://www.test.com/en/section/string-to-get#id=4949
https://www.test.com/en/section/string-to-get/page&2#id=4949'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end