import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "( )(\\d+)";
final String string = "1. Moore, Roger\n"
+ "2. Connery, Sean\n"
+ "3. ....\n"
+ "100. Dalton, Timothy\n"
+ "110. Bronson, Pierce 111. Gomez, Selena 112. Portman, Nathalie";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}