# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(https?:\/\/)|(\/)+/$1$2/g;t' <<< "http://127.0.0.1:7000//test//test//index.html"