using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<days>\d+(?= д.))?(?<hours>\d+(?= ч.))?(?<minutes>\d+(?= м.))?";
string input = @"5 д. 1 ч. 23 м.
17 ч. 44 м.
12 д. 17 ч.";
RegexOptions options = RegexOptions.CultureInvariant;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}