package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?P<code_1>\d+-\d+)(?:\s*,\s*(?P<code_2>\d+-\d+))?(?:\s*,\s*(?P<code_3>\d+-\d+))?$`)
var str = `21-1091, 21-1094, 21-1099`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}