import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?>(?:\"\"[^\"\"\\n]*\"\"|[^;\"\"\\n]+)*)\"\"?[^\"\";\\n]*(;.*)";
final String string = "Peekaboo ; A comment starts with a semicolon and continues until the EOL\n"
+ "...unless the semicolon is surrounded by unescaped dquotes \"Don’t do it ; here\" ;but match me; once\n"
+ "Im not surrounded \"so pay attention to me\" ; \"peekaboo\"\n"
+ "Im not surrounded \"so pay attention\" to;me\" ; \"peekaboo\"\n"
+ "Im not surrounded \"so pay attention to me ; peekaboo\n"
+ "Dquote escapes a dquote so \"dont pay attention to \"\"me;here\"\" buster\" do it ; here\n"
+ "Don’t pay attention to \"\"\"me;here\"\"\" but do \"\"it;here\"\"\n"
+ "and \"dont do \"\"it;here\"\"\" either ;peekaboo\n"
+ "but \"pay attention to \"it;here\"\" ;not here though\n"
+ "Simon said \"I like goats\" then he added \"and sheep;\" ;a good comment is \"here\n"
+ "Simon said \"I like goats\" then he added \"and sheep;\" dont do it here\n"
+ "Simon said \"\"I like goats;\"peekaboo\n"
+ "Simon said \"I like goats;\"\"peekaboo";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}