import Foundation
let pattern = #"(\w+)( +and +)(\w+)( +[^,]*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"Heather Robinson, Jane and John Smith, Kiwan and Nichols Brady John, Jimmy Nichols, Melanie Carbone, and Nancy Brown"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1\4\2\3\4"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)