$re = '/(?:^\(|\G(?!^),)("[A-Z]+")(?=(?:,"[A-Z]+")*\)$)/m';
$str = '("JOY","SAD")
("JOY","sad")
("JOY",0)
("JOY","\'")
("JOY",SAD)
("JOY","")
("")
("0")
(a)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);