re = /(\d+)\s(Yanvar|Fevral|Mart|Aprel|May|İyun|İyul|Avqust|Sentyabr|Oktyabr|Noyabr|Dekabr)/m
str = '1 Yanvar
2 Fevral
3 Mart
4 Aprel
5 May
6 İyun
7 İyul
8 Avqust
9 Sentyabr
10 Oktyabr
11 Noyabr
12 Dekabr'
subst = '$1 \\L$2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result