#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)Property?\s+(\w+)\s*(\([^()]+\))"
Local $sString = "Public ReadOnly Property Test(v as String) As Integer" & @CRLF & _
"Public ReadOnly Property Test(ByVal v as String) As ReadOnlyCollection(Of Guid)" & @CRLF & _
"Public ReadOnly Property Test() As Integer " & @CRLF & _
"Public ReadOnly Property Test() As ReadOnlyCollection(Of Guid)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")