#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=,|\t)(.*?)(?=,|\n)"
Local $sString = " marjorie.bienert@soprasteria.com,adel.amari@ext.soprasteria.com,marcos.martinez@soprasteria.com,angeline.marie@soprasteria.com,frederic.lecomte2@soprasteria.com,stephane.gaston@sante.gouv.fr,juan-cristobal.peinado@soprasteria.com,philippe.bourdin@sante.gouv.fr,alejandro-horacio.ramos@soprasteria.com,thomas.bernstein@soprasteria.com,iman.ouazzani@soprasteria.com,anthony.jacq@soprasteria.com,jorge.moraistejerina@soprasteria.com,camille.rolland@soprasteria.com,sebastien.dufay@soprasteria.com,soufiane.mouflih@ext.soprasteria.com,adama.sakho@soprasteria.com,deuneuv.makoundou@soprasteria.com,manel.bejaoui@soprasteria.com,etienne.lorteau@soprasteria.com,javier.pina@soprasteria.com,paloma.fernandez@soprasteria.com,victoire.legrand@soprasteria.com,timothee.luyt@soprasteria.com,francisco-javier.soriano@soprasteria.com,christophe.lauv@soprasteria.com,thibault.louis@soprasteria.com,yolanda.torres@soprasteria.com" & @CRLF & _
"admin.platines@asipsante.fr E A noreply.platines@asipsante.fr" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")