package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<your_field>.*)_\d`)
var str = ` a_b_c_9`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}