use strict;
my $str = '/*https://www.geradordecpf.org/*/
784.267.866-93
087.465.490-48
747.507.895-77
55465881798
554.658.817-98
554.AA9.817-98
554.658.817/98
554-658.817/98
577 333 506 97
78913560178';
my $regex = qr/^((\d{11})|((\d{3}[-.\/]){3}\d{2}))$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}