$re = '/^(?:[$](\s{0,1})|)[+-]?(\d{1,3},?(\d{3},?)*\d{3}(\.\d{0,2})?|\d{1,3}(\.\d{0,2})?|\.\d{1,2}?)$/m';
$str = '//OK TESTS
0.12
2,000,000.00
$1.23
$ 1.23
-1233
$ -123
$-123
.12
$ .12
$-.12
//NEGATIVE TESTS
12.123
3.3.3
.2.2.
$$123.11
$12.$123
$ 123.2
.00.00
.0.0
...0
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);