package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\[(.+?)\]`)
var str = `[text1]Blablablabla[text2]blalal
[text1]Blablablabla[text2]blalal [text1]Blablablabla[text2]blalal`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}