import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(contrat|bail|engagement)(\\sde)? (flexible|courte dur[ée]e|sans engagement)";
final String string = "contrat flexible\n"
+ "bail flexible\n"
+ "bail de courte durée\n"
+ "contrat de courte durée\n"
+ "engagement de courte durée\n"
+ "contrat sans engagement\n"
+ "bail sans engagement\n"
+ "bail courte durée\n\n"
+ "contrat flexible de mise à disposition\n"
+ "bail de courte durée renouvelable\n"
+ "contrat flexible de prestation de service\n"
+ "contrat flexible et de courte durée\n\n"
+ "bail flexible (engagement minimum x mois)\n"
+ "contrat de courte durée (x mois à x ans)\n"
+ "bail de courte durée : x à x ans\n"
+ "bail de courte durée de x mois\n"
+ "bail flexible sur x ans \n"
+ "bail de courte durée jusqu'au xx/xx/xxxx";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}