import Foundation
let pattern = #"(contrat|bail|engagement)(\sde)? (flexible|courte dur[ée]e|sans engagement)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
contrat flexible
bail flexible
bail de courte durée
contrat de courte durée
engagement de courte durée
contrat sans engagement
bail sans engagement
bail courte durée
contrat flexible de mise à disposition
bail de courte durée renouvelable
contrat flexible de prestation de service
contrat flexible et de courte durée
bail flexible (engagement minimum x mois)
contrat de courte durée (x mois à x ans)
bail de courte durée : x à x ans
bail de courte durée de x mois
bail flexible sur x ans
bail de courte durée jusqu'au xx/xx/xxxx
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)