$re = '/^[^A-Za-z\n]*[A-Za-z].*$/m';
$str = 'alpha
Alpha1
A35. 1ha
Alp1Ha
A pha6
12345
0
-23442';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);