# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*/\1/gmi;t' <<< "This is test string for my app. d
This is test string for my app.
This is test string for my app. abcd
This is test string for my app.
This is test string for my app.
This is test string for my app.
This is test string for my app. d
This is test string for my app.
This is test string for my app.
This is another string."