use strict;
my $str = 'This is test string for my app. d
This is test string for my app.
This is test string for my app. abcd
This is test string for my app.
This is test string for my app.
This is test string for my app.
This is test string for my app. d
This is test string for my app.
This is test string for my app.
This is another string.';
my $regex = qr/^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*/mip;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";