import Foundation
let pattern = #"^(([^\n\r.]*).*)(?:(?:\r?\n|\r)\2.*)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .caseInsensitive])
let testString = #"""
This is test string for my app. d
This is test string for my app.
This is test string for my app. abcd
This is test string for my app.
This is test string for my app.
This is test string for my app.
This is test string for my app. d
This is test string for my app.
This is test string for my app.
This is another string.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)