package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`utm_campaign=([^&]+)`)
var str = `utm_source=google&utm_campaign=Test | Test - Exact&utm_test=test`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}