re = /utm_campaign=([^&]+)/
str = 'utm_source=google&utm_campaign=Test | Test - Exact&utm_test=test'
# Print the match result
str.match(re) do |match|
puts match.to_s
end