using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w+)(:.*?)(?=\s+\w+:|$)";
string substitution = @"<b>$1</b>$2";
string input = @"aaaaa: lorem ipsum bb: do lor sit amet ccc: no pro movet";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}