#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?ms)BEGIN:VEVENT.*?END:VEVENT"
Local $sString = "BEGIN:VEVENT" & @CRLF & _
"DTSTAMP:20220301T023567Z" & @CRLF & _
"UID: xxx" & @CRLF & _
"DTSTART;TZID=Asia/Tokyo:20210630T110000" & @CRLF & _
"DTEND;TZID=Asia/Tokyo:20210630T160000" & @CRLF & _
"DESCRIPTION:\n--------\n同日入替 : false\n前回ゲスト数 : 1\n次" & @CRLF & _
"SUMMARY: xxxxx (xxx / xxx xxx" & @CRLF & _
"END:VEVENT" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTAMP:20221105T072143Z" & @CRLF & _
"UID: xxx" & @CRLF & _
"DTSTART;TZID=Asia/Tokyo:20210501T110000" & @CRLF & _
"DTEND;TZID=Asia/Tokyo:20210701T160000" & @CRLF & _
"DESCRIPTION:\n--------\n同日入替 : false\n前回ゲスト数 : 1\n次" & @CRLF & _
"SUMMARY: xxx (xxx / xxx xxx)" & @CRLF & _
"END:VEVENT" & @CRLF & _
"BEGIN:VEVENT" & @CRLF & _
"DTSTAMP:20220905T023143Z" & @CRLF & _
"UID: xxx" & @CRLF & _
"DTSTART;TZID=Asia/Tokyo:20220227T110000" & @CRLF & _
"DTEND;TZID=Asia/Tokyo:20220227T160000" & @CRLF & _
"DESCRIPTION:\n--------\n同日入替 : true\n前回ゲスト数 : 2\n次回" & @CRLF & _
"SUMMARY:★ xxx (xxx / xxx xxx)" & @CRLF & _
"END:VEVENT"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")