package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([\d\w,"])|(\[\])|({})`)
var str = `[1, [], [3, [[4]]]]
[1, {}, [3, [[4]]]]
[[["a"]], [["b"]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}