$re = '/^\d{1,3}(?:,\d{1,3}){0,3}(?: ; \d{1,3}(?:,\d{1,3}){0,3})*$/m';
$str = '10
10,10 ; 5,5
10,11,12,13 ; 20,30 ; 50
10 ,
10,10,999 ; 10,10 ,;
10,10 ; , 10;10,10
10 ;; 10';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);