use strict;
my $str = 'CamelCaseForTheWin
ACar
BuyACar
XML
SimpleXML
';
my $regex = qr/(?<!^)[A-Z]/mp;
my $subst = '_$0';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";