#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Integrity checksum changed for:\s\'(?<pathName>[^\']+)"
Local $sString = "2016 Oct 30 19:13:08 (AAV) 145.46.122.14->syscheck-registry" & @CRLF & _
" Rule: 596 (level 5) -> 'Registry Integrity Checksum Changed Again (3rd time)'" & @CRLF & _
" Integrity checksum changed for: 'HKEY_LOCAL_MACHINE\Security\SAM\Domains\Account'" & @CRLF & _
" Old md5sum was: '27511968a811898f0d7f1fed393d31d7'" & @CRLF & _
"5. New md5sum is : '5876c6ae278cce7ff2108d8396e10ddc'" & @CRLF & _
" Old sha1sum was: 'd94f9ea544b6b04caabc80d5bbe6b94854ae3406'" & @CRLF & _
" New sha1sum is : 'b46d17a3ddc54b5d03464374514398a1835f857e'" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"2016 Oct 29 06:53:09 (AAB) 145.46.40.146->syscheck-registry" & @CRLF & _
" Rule: 594 (level 5) -> 'Registry Integrity Checksum Changed'" & @CRLF & _
" Integrity checksum changed for: 'HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Tomcat'" & @CRLF & _
" Old md5sum was: '3288a8f072b45b2fa9d879b2ba0fe453'" & @CRLF & _
"5. New md5sum is : 'ff17914ec4722e9b7d3scdb508c5d55d'" & @CRLF & _
" Old sha1sum was: '4d6b33e40721s837cd8de090ef0468b6b20a1f3b'" & @CRLF & _
" New sha1sum is : '270dca37b8681ca739de4493b704333fb3be86a3'" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")