import Foundation
let pattern = #"(?:\G(?!^)\",|\"Name\":\[)\"\K[^\"]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"{"Name":["Jobs","Bill"]}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"******"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)