import Foundation
let pattern = ##"(((http|https):\/\/)|www\.)+[-a-zA-Z0-9@:%._\+~#=]{2,256}\.[a-z^0-9]{2,6}\b([-a-zA-Z0-9@:%_\+.~#?&//=]*)"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://google.com
https://google.com
http://www.google.com
https://www.google.com
www.google.com
http://google.com/gaga
https://google.com/gaga
http://www.google.com/gaga
https://www.google.com/gaga
www.google.com/gaga
http://130.211.9.113
https://130.211.9.113/gaga
ftp://google.com
130.211.9.113.de
google.com
google.com/gaga
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)