Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
r"
\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b
"
gm
Input 1
1
New
02:33 2:33 12:22:32 The time is 23:33 it's12:34 12:33:34455 44:45 25:50:02 18:78 2A:3E:EE