import re
regex = re.compile(r"\b([01]?[0-9]|2[0-3]):([0-5][0-9])(?::([0-9][0-9]))?\b", flags=re.MULTILINE)
test_str = ("02:33\n"
"2:33\n"
"12:22:32\n"
"The time is 23:33\n"
"it's12:34\n"
"12:33:34455\n"
"44:45\n"
"25:50:02\n"
"18:78\n"
"2A:3E:EE\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")