$re = '/(.*)(-[a-zA-Z0-9]+(.)(.*))/';
$str = 'NameOfFile-354-XX.pdf';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);