Please enable JavaScript to use regex101
/
^
r
e
g
e
x
[
\
-
_
]
?
1
0
1
$
/
i
Reg
ular
Ex
pressions
101
Reg
ular
Ex
pressions
101
Upgrade to Pro
Enterprise
Regular Expression
/
(25[0-5]|2[0-4]\d|1?\d\d?)(\.\g<-2>){3}
/
gm
Input 1
1
New
123 hahab abcde 123 //192.168.10.254/10.4.32.21 / 1.2.3 /125.258.33.22/ 432.2.3.475
Substitution