# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(25[0-5]|2[0-4]\d|1?\d\d?)(\.\g<-2>){3}"
test_str = ("123 hahab abcde 123\n"
"//192.168.10.254/10.4.32.21 / 1.2.3 /125.258.33.22/ 432.2.3.475")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.