re = /<span>(.*?)<\/span>/
str = '</span><span>wanna-string</span></a>'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result