import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(one|three|four)\\s*,\\s*(?!\\1)(one|three|four)\\s*,\\s*(?!\\1|\\2)(one|three|four)";
final String string = "one,three,four apple is red. should be match\n\n"
+ "four, three, one orange is orange. should be match\n\n"
+ "one,four,three the sky is blue. should be match\n\n"
+ "one,two,four,three should not be match because two is between the group of words\n\n"
+ "four,one,eight,green,three also not because eight and green is between the group of selected words";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}