$re = '/^(?:[^_\n]*_){9}(CON)(?:_|$)/m';
$str = 'DI_NEO_OP_BRA_CRC_LRN_DIS_EP_NA_CON_UC_NA
DI_NEO_OP_BRA_CRC_LRN_DIS_EP_NA_CON';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);